Home   Archive   Permalink

How to use R3 on Mac?

I have downloaded the source binary from rebol.org, and double-clicked it, but nothing happens. I am new to Mac and now am quite confused...

posted by:   Rex       5-Apr-2014/10:31:28-7:00

I can't answer your question, but it points out what I personally hope would still be the goal of those working on R3. A person should be able to download it, double-click it, and run it. It was very close to that with R2, probably as close as could reasonably be done, and it was wonderful. Not on the Mac, of course, and also a bit fussy on GNU/Linux.

posted by:   Steven White       5-Apr-2014/21:23:09-7:00

I am with you there Rex. The mac versions are problematic, so I guess there is not much push for mac versions. For me, is Rebol worth returning to those awful Microsoft machines? I dunno.

posted by:   Ignosis       5-Apr-2014/22:00:21-7:00

I have purchased Crossover for Macintosh and run the Windows version of REBOL 2 under it. It seems to work, but I haven't tested it heavily.

posted by:   Steven White       5-Apr-2014/23:15:34-7:00

Yeah, I do hope the Mac version will be as easy and powerful as the windows version. Besides, I use VMware to run windows on Mac, but there seems to be a few problems with R3: Sometimes I cannot just get it started.

posted by:   Rex       6-Apr-2014/20:51:31-7:00

Off topic, how well does that work to run Windows with VMware? I would like to move our old Windows XP computer to the Mac and keep using it for a while, but I hesitate to spend the money and find out that I can't for some reason. Is VMware Fusion the product you use to make that work? Thank you.

posted by:   Steven White       6-Apr-2014/21:30:03-7:00

This week Cyphre mentioned that he is currently "working on improvements of the R3 code base. Fixing crashes, merging things from Atronix etc. Also we are adding back the EFFECT dialect to R3 with some enhancements comparing to the R2".
Here is some of the pipeline which he mentioned prioritizing last week:
-improving Android port
-start OSX port
-start JS port
-openGL graphics backend
-other possible improvements
My preference is dramatically towards JS port, to get it on every platform, mobile, etc.    
I'm not sure what the guys from Atronix are prioritizing. They just posted their first releases of ports for Linux and Win (32 bit and 64 bit) a few weeks ago. I imagine they're busy tidying up those releases.
Either way, progress has been strong (just not very public).

posted by:   Nick       7-Apr-2014/0:26:46-7:00

Rex, are you unable to use R2 for Mac?

posted by:   Nick       7-Apr-2014/0:27:25-7:00

I think VM is okay. And it has a function called "unity", which fuses the windows program into Mac OS, and this is cool. But it has a few problems too. One is energy-consuming. Whenever I use VM, the battery always complains of heavy load. The other is the clipboard. Whenever I try to cut-n-paste from Mac OS to windows, there is something wrong. And I am wondering why.

posted by:   Rex       7-Apr-2014/2:23:14-7:00

I am also quite excited about the progress going on, esp. the fusion with Java (can we call it Jrebol, as the ruby on Java is called Jruby?). I do hope it will be available soon. Right now I have to stick with R3, because in my daily work I have to shift between different languages. I never tried to use R2 on Mac, and thus don't know whether it works on that platform.

posted by:   Rex       7-Apr-2014/2:26:57-7:00

Do you have a link to the Rebol3 binary on rebol.org that you used? And what version of Mac OSX are you using?    
I've used OS X x86 binaries from rebolsources.net & Saphiron on OS X Lion with no issues. And was also successful compiling Rebol 3 straight from the source (from http://github.com/rebol/rebol)

posted by:   Barry       7-Apr-2014/10:48:34-7:00

I use Mac OS X 10.9.2, and I just don't know how to get R3 to run, I tried double-click but it doesn't work.

posted by:   Rex       8-Apr-2014/3:25:32-7:00

To get REBOL to run on a Mac or Linux, make sure that permissions are set first.
Open a terminal, go to the directory, where the REBOL you want to run is and type:
    chmod 755 r3-osx
Replace "r3-osx" with the name of the binary.
Now you can run it in the terminal:
To allow running it from any terminal without having to go into that directory, copy the r3-osx binary to /usr/bin.
Then you can, in a new terminal, simply type:
and it will run.
Making programs run on a Mac and support more than just the plain UNIX underpinnings, i.e. use the Mac menu bar, requires some legwork, which is not done yet.

posted by:   Henrik       8-Apr-2014/5:23:54-7:00

Thanks, Henrik, it works. But there seems to be some problems with I/O. i.e. whenever I try to use 'read to read from a webpage, it reports an error, saying that I have no access to the Internet. But I do have access.

posted by:   Rex       8-Apr-2014/7:07:14-7:00

If you are using a proxy, it may be necessary to set that up, but I'm unaware if R3 supports proxies yet.

posted by:   Henrik       8-Apr-2014/11:16:18-7:00

Rex, If it's not a proxy issue then your problem maybe firewall and/or gatekeeper related.

posted by:   Barry       8-Apr-2014/18:28:54-7:00

I tried again this morning, and somehow the internet worked this time. Thanks!

posted by:   Rex       9-Apr-2014/7:17:42-7:00