Home   Archive   Permalink

REBOL 2.7.8 No Console Prompt on linux

I am trying to use Rebol 2.7.8 on ubuntu linux everything seems to work with one exception I get no console prompt. Anyone have any ideas.

posted by:   Jrichards       12-Apr-2011/13:06:51-7:00

Run REBOL from the console:
Open a terminal window (Applications -> Accessories -> Terminal)
cd the directory that contains REBOL
Type "./rebview" (without the quotes), or "./rebol", depending on the version you've downloaded.
Another, maybe better, option is to try the linux packages by MaxV:    
(.deb should work on ubuntu)

posted by:   Nick       12-Apr-2011/21:00:55-7:00

Thanks Nick, I've actually tried your suggestions and I am still running into the same problem. Tried the .deb packages tried Fedora, I'm lost.

posted by:   Jrichards       13-Apr-2011/18:55:09-7:00

It's been a while since I used REBOL in Ubuntu, so I think I was using version 2.76. I do remember having the same problem, and the key was to launch REBOL from the Unbuntu console - if I remember correctly, REBOL will use the same console session from which it was launched, as it's console window, so be sure to keep it open after launching REBOL.

posted by:   Nick       13-Apr-2011/23:25:58-7:00

If you are talking about REBOL/View, that has a bug that prevents you on clicking the Console icon in the View desktop.
However, this is not the original Linux console. If you start REBOL/Core on Linux, you get into the REBOL console immediately. If you use REBOL/View on Linux, you need to use the -v option to prevent it from opening a window.

posted by:   Kaj       14-Apr-2011/11:48:44-7:00

Thanks Kaj, tried your suggestion it doesn't work. I get the console prompt but it accepts no input. I am having the same problem with 2.7.7

posted by:   Jrichards       15-Apr-2011/18:03:03-7:00

Which Ubuntu version are you running? That may be of help.

posted by:   Henrik       16-Apr-2011/3:47:25-7:00

I'm running Ubuntu 10.04 I had 2.7.7 of view running for a couple of months and then all of a sudden it stopped working. Are there any external libs that Rebol uses on a Linux box?

posted by:   Jrichards       16-Apr-2011/10:37:05-7:00

Did this happen right after an (automatic) update of Ubuntu? That would be the most likely cause. REBOL needs a number of system libraries, and it sounds like something has changed in there.

posted by:   Kaj       16-Apr-2011/16:11:08-7:00

I suspect that is what happened Kaj, I am going to have to tracking down the problem. I did an ldd on Rebol but that seems to look good. Still digging.

posted by:   Jrichards       18-Apr-2011/15:35:18-7:00

You can try REBOL 2.7.8, and there are also multiple versions for Linux these days, built on different versions of the system libraries.

posted by:   Kaj       19-Apr-2011/16:10:27-7:00

http://www.maxvessi.net/rebsite/Linux/ install the 2.7.8, you'll find the rebol app in the application menu, under "Development".

posted by:   MaxV       21-Apr-2011/4:25:07-7:00