Home   Archive   Permalink

'call' function in Windows 10

I have this program I run once a year to extract data from a spreadsheet using powershell (because that is the only way I know to do it). I call the powershell script in this way:
CMD-STRING: reduce [
     " powershell -Command L:\SPECIALS\GenLevyTable.ps1 "
     to-local-file SPREADSHEET-NAME
call/wait CMD-STRING
The CMD-STRING reduced down to:
>> print cmd-string
powershell -Command L:\SPECIALS\GenLevyTable.ps1 L:\COMMON\specasmt\spreadsheets\Copy-of-Pay2018-RATE-TABLE.xlsx
I have at my desk access to the computer I used last year which runs Windows 7, and the computer I am using this year which runs Windows 10. The REBOL program is on our network which I can access from both computers, so I have tried the exact same REBOL script on each computer and it works on Windows 7 and not on Windows 10. I also have determined that the powershell script runs on Windows 10 when NOT called by my REBOL program, so I know the issue is in the calling operation.    
Does anyone have any thoughts on making things work on Window 10 that worked fine on Windows 7? I worry that some day when Windows marches far enough along, REBOL 2 will just quit working in enough key areas that it will in effect be dead.
Thank you.    

posted by:   Steven White     30-Nov-2017/11:35:03-8:00

I'd be willing to bet you need to use call/show, instead of 'call. The operation of 'call changed during the last few releases of Rebol2 - call/show switched between being default and a refinement. If you had a slightly different version of Rebol on each machine, that would explain the difference. Call/show does work in Windows 10.

posted by:   Nick     30-Nov-2017/21:53:47-8:00