Home   Archive   Permalink

trying rebol on linux not working

I am a first time user of rebol on linux. I normally use MS windows
I downloaded the rebol and use the tar command to extract the files, then I call the rebol executable, but it gives me error 'command not found' . anybody can help me find what is wrong ? what did i do wrong ?
I tried the same with the view rebol version, same error.
Linux porteus 4.9.0-porteus
guest@porteus:~/Downloads/releases/rebol-core$ ls -l
total 368
-rw-r--r-- 1 guest users 1794 Jan 7 2011 about.txt
-rwxr-xr-x 1 guest users 369128 Jan 7 2011 rebol*
guest@porteus:~/Downloads/releases/rebol-core$ rebol
bash: rebol: command not found

posted by:   porteus     4-Jan-2017/12:05:50-8:00

Firstly, make sure the binary is executable:
     chmod +x rebol
As the binary isn't in your PATH, you'll need to include the directory (relative will suffice) when calling:
Also, this page is worth a wee look over to get started with scripting with Rebol on *ix:

posted by:   Chris     4-Jan-2017/15:07:59-8:00

I too am vexed by REBOL on non-windows, but still would like to go there. So I have started to document how to get it running on every computer I have access to, which unfortunately is not many. Only one. I have documented my experience with opensuse 13.2 at the link below. This is not your specific situation, so your procedure will be different, but maybe my experience will help in some general way. The notes above, about making rebol executable and remembering the "dot-slash" if rebol is not in your path, are common oversights that I myself keep making.    

posted by:   Steven White     4-Jan-2017/19:58:22-8:00

I found these to be helpful: http://www.maxvessi.net/rebsite/Linux/index.php

posted by:   Harold     10-Jan-2017/6:19:16-8:00

Maybe this too:

posted by:   Harold     10-Jan-2017/6:23:28-8:00