Home   Archive   Permalink



Rebol CGI on IIS6?

Anyone uses Rebol as a CGI on IIS? I did it before, but I cannot make it run today.
I put rebol.exe and test.r files under wwwroot, configured .r files to run by rebol.exe as cgi.
I gave everyone read/execute access to both files. test.r file start with #!rebol.exe -cs also tried #!rebol.exe -cswiv (no window, no install etc)
rebol.exe process stays open on background, and no response at all.
Any idea?

posted by:   Endo       24-Jun-2010/4:50:26-7:00



Hmm somehow IIS ignores the command line parameter -cs. So rebol.exe starts as a console in background.
I tried to give it from the IIS properties window and also from first line of the script. But no chance.

posted by:   Endo       24-Jun-2010/4:56:52-7:00



Ok. I got it work.
It worked when I set executable path as
"C:\Inetpub\wwwroot\cgi-bin\rebol.exe" -cs %s %s
    
Note that the path is quoted. parameters aren't.


posted by:   Endo       24-Jun-2010/5:49:12-7:00



Thanks for posting that Endo - I'm sure I'll need that at some point!

posted by:   Nick       24-Jun-2010/9:28:20-7:00



I have problems when uploading a file. I'm not sure what is wrong.
    
my send.html file is like this:
     <form name="xx" method="post" action="getfile.r" enctype="multipart/form-data">
     <input type="file" name="file"></form>
    
and the getfile.r file is:
     data: read-cgi
even if I do this:
     data: copy ""
     read-io system/ports/input data 1024
it waits forever and nothing happens.


posted by:   Endo       25-Jun-2010/18:56:34-7:00



Search for the "decode-multipart-form-data" function in the CGI section of the tutorial at http://re-bol.com.

posted by:   Nick       26-Jun-2010/10:29:06-7:00