Home   Archive   Permalink



Email Errors

Hey there. I'm new to REBOL and programing in general, so be warned. I'm having problems in getting REBOL scripts to send emails. I keep getting:
    
** User Error: Server error: tcp 530 5.7.0 Must issue a STARTTLS command first. db3sm5123220pbb.10 - gsmtp
** Near: insert smtp-port reduce [from reduce [addr] tmp]
    
Example when I run:
    
R E B O L []
            
do %prot-ssmtp.r
do %prot-ssend.r
            
set-net [myemail@gmail.com smtp.gmail.com none none none none myemail@gmail.com "password" ]
            
send myemail@gmail.com "Hello ... test message"
            
print "Done"
halt
    
it returns that error.
    


posted by:   Jason       27-Mar-2014/3:45:12-7:00



ah...figured it out ssend...sheesh.

posted by:   Jason       27-Mar-2014/4:38:32-7:00



I am having a hell of a time trying to attach a file, though...any help on that front?

posted by:   Jason       28-Mar-2014/3:13:01-7:00



ssend/attach works with Gmail (change username/password):
    
R E B O L []
do %prot-ssmtp.r
do %prot-ssend.r
set-net [username@gmail.com smtp.gmail.com none none none none username@gmail.com "password" ]
ssend/attach recipient@site.com "Hello ... test message" request-file/only
print "Done"
halt

posted by:   Nick       29-Mar-2014/15:22:57-7:00



Send has the same /attach refinement and I'm able to use it with my servers (so I haven't tried ssend anywhere else but with Google).

posted by:   Nick       29-Mar-2014/20:10:31-7:00